Scheduled Maintenance

Incident Report for Welltory app

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 09:19 UTC

Investigating

We’re carrying out routine maintenance of our systems. You may experience temporary issues with the app, but it will get back to normal soon.
Posted Dec 09, 2025 - 08:54 UTC
This incident affected: Welltory systems.