Server issues

Incident Report for Welltory app

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:18 UTC

Identified

We're experiencing server issues and are currently looking into the problem.
Posted Oct 20, 2025 - 15:45 UTC
This incident affected: Welltory systems.